Ticket #1909 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Plugable EXTFS VFS

Reported by: andrew_b Owned by: andrew_b
Priority: major Milestone: 4.7.2
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description (last modified by andrew_b) (diff)

Currently, the each external (EXTFS) VFS type must be registered in extfs.ini file. It difficult to use third-party plug-ins. I propose to use extfs.ini.d directory instead of extfs.ini file. This directory will contain uzip, rpm, deb, a:, dpkg: etc. files. Each file can be empty or contain some comments. If some filesystems cannot contain files with colon symbol in name, we can use 'a+' or another filename template instead of 'a:'.

Change History

comment:1 Changed 7 years ago by andrew_b

  • Summary changed from Simple plugable VFS to Plugable SFS VFS

comment:2 Changed 7 years ago by andrew_b

Actually, this ticket is duplicate of #1677.

comment:3 Changed 7 years ago by andrew_b

  • Blocked By 1677 added

comment:4 Changed 7 years ago by angel_il

my vote for:
a+, dpkg+, etc...

comment:5 Changed 7 years ago by andrew_b

  • Blocking 1677 added
  • Blocked By 1677 removed

comment:6 Changed 7 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Version changed from version not selected to master
  • Milestone changed from VFS Standardization to 4.7.1

comment:7 Changed 7 years ago by andrew_b

  • severity changed from no branch to on review

Created 1909_extfs_d branch. Parent branch is master.
Initial changeset:b959f45d5fe70e276eff0f04444dc390eaeeab31

Please review.

comment:8 Changed 7 years ago by andrew_b

  • Description modified (diff)
  • Summary changed from Plugable SFS VFS to Plugable EXTFS VFS

comment:9 Changed 7 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:10 Changed 7 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • severity changed from on review to approved

comment:11 Changed 7 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko angel_il to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

Merged to master.
changeset:de0cac20e38fa512977c52f92fdbea9fcbe58b15

git log --pretty=oneline 111750d..de0cac2

comment:12 Changed 7 years ago by slavazanko

  • Keywords stable-candidate added

comment:13 Changed 7 years ago by andrew_b

  • Status changed from testing to reopened
  • Votes for changeset commited-master deleted
  • severity changed from merged to on review
  • Type changed from enhancement to defect
  • Version changed from master to 4.7.1
  • Milestone changed from 4.7.1 to 4.7.2
  • Resolution fixed deleted

If EXTFS plugin doesn't require a file, that file name must be finished with '+': for example, rpms+. But trailing '+' actually is not a part of plugin name, it is an plugin attrubute.
But in the current time trailing '+' must be used in VFS command:

$ cd #rpms+

instead of

$ cd #rpms

In addition, cd #rpms+ is broken.

I propose to simplify the usage of some EXTFS plugins.

Created 1909_extfs_d_plugin_name branch. Parent branch is master.
changeset:da6bde70e987aa4ef900d47165ef9d5cb4bf2e95

comment:14 Changed 7 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:15 Changed 7 years ago by iNode

  • Votes for changeset changed from slavazanko to slavazanko iNode

comment:16 Changed 7 years ago by iNode

  • severity changed from on review to approved

comment:17 Changed 7 years ago by andrew_b

  • Status changed from reopened to closed
  • Votes for changeset changed from slavazanko iNode to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:18 Changed 7 years ago by andrew_b

  • Status changed from closed to reopened
  • Votes for changeset commited-master deleted
  • severity changed from merged to on rework
  • Priority changed from minor to major
  • Version changed from 4.7.1 to master
  • Resolution fixed deleted

"." and ".." directories within archives are handled incorrectly.
Bug was introduced in changeset:ad9c1daad88d4972f81fd73ab06fb8b90027cb7a.

Created 1909_extfs_read_archive_fix branch. Parent branch is master.

Stable branch doesn't contain this bug because plugable EXTFS is not back-ported yet.

comment:19 Changed 7 years ago by andrew_b

  • severity changed from on rework to on review

comment:20 Changed 7 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:21 Changed 7 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • severity changed from on review to approved

comment:22 Changed 7 years ago by andrew_b

  • Status changed from reopened to closed
  • Votes for changeset changed from slavazanko angel_il to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:23 Changed 7 years ago by andrew_b

  • Keywords stable-candidate removed

Cherry-picked to 4.7.0-stable.

First changeset:4c171cc991ad5b481eb8424626b33cc25d9b9182
Last changeset:3a076f439e65616e225023fd0afc072a44517aac

git log --pretty=oneline 038011f..3a076f4

comment:24 Changed 7 years ago by andrew_b

  • Blocking 1677 removed
Note: See TracTickets for help on using tickets.