Ticket #2821 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

ftp to a second site does not work

Reported by: gv Owned by: slavazanko
Priority: major Milestone: 4.8.4
Component: mc-vfs Version: master
Keywords: Cc: gabriel@…
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

  1. cd ftp://ftp.somesite.com/
  2. Directory three in the panel look ok.
  3. Run "cd" in the panel where the remote site is open
  4. cd ftp://ftp.anothersite.com
  5. The directory three in the panel is from the first opened site.

Change History

comment:1 Changed 4 years ago by gv

  • Cc gabriel@… added

comment:2 Changed 4 years ago by andrew_b

  • Component changed from mc-core to mc-vfs

comment:3 Changed 4 years ago by andrew_b

Works as expected for me. I tried ftp.gnome.org and ftp.gtk.org.

comment:4 Changed 4 years ago by gv

Partial screen-shot:

# cd ftp://ftp.gnome.org/
l<q ftp://ftp.gnome.org/ qqqqqqqqqqqqqq
x'n Name x
x/.. x
x~Public x
x/about x
x/cdimage x
x/conspiracy x
x~debian x
x~debian-cd x
x~debian-non-US x
x/mirror x
x/pub x
x~releases x
x~ubuntu x
x HEADER.html x
x favicon.ico x
x robots.txt x
x welcome.msg x
x welcome2.msg x

# cd
# cd ftp://ftp.gtk.org/

l<q ftp://ftp.gtk.org/ qqqqqqqqqqqqqqqq
x'n Name x
x/.. x
x~Public x
x/about x
x/cdimage x
x/conspiracy x
x~debian x
x~debian-cd x
x~debian-non-US x
x/mirror x
x/pub x
x~releases x
x~ubuntu x
x HEADER.html x
x favicon.ico x
x robots.txt x
x welcome.msg x
x welcome2.msg x

Quit mc.

# cd ftp://ftp.gtk.org/
l<q ftp://ftp.gtk.org/ qqqqqqqqqqqqqqqq
x'n Name x
x/.. x
x/etc x
x/incoming x
x/lost+found x
x/pub x

comment:5 Changed 4 years ago by slavazanko

  • Status changed from new to accepted
  • Owner set to slavazanko

comment:6 Changed 4 years ago by slavazanko

  • Keywords stable-candidate added
  • Branch state changed from no branch to on review

Created branch 2821_wrong_second_ftp_connection

Review, please.

comment:7 Changed 4 years ago by andrew_b

  • Votes for changeset set to andrew_b

comment:8 follow-up: ↓ 9 Changed 4 years ago by gv

Works for me.
Also it seems to fix the same problem but for archive files.

comment:9 in reply to: ↑ 8 ; follow-up: ↓ 10 Changed 4 years ago by andrew_b

Replying to gv:

Works for me.
Also it seems to fix the same problem but for archive files.

extfs is broken by design: #62

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 11 Changed 4 years ago by gv

Replying to andrew_b:

extfs is broken by design: #62

I'm aware of that. But was not the case.

Create a.tar.gz and b.tar.gz. Press enter on a.tar.gz. See all the files inside. Press enter on b.tar.gz and see all the files in a.tar.gz (this works correctly prior to 4.8.4). No rename/delete/etc.

After this patch I cannot reproduce-it.

comment:11 in reply to: ↑ 10 ; follow-up: ↓ 12 Changed 4 years ago by andrew_b

Replying to gv:

Create a.tar.gz and b.tar.gz.

tar is not processed via extfs. tarfs is a separate vfs. cpio too.

comment:12 in reply to: ↑ 11 Changed 4 years ago by gv

Replying to andrew_b:

tar is not processed via extfs. tarfs is a separate vfs. cpio too.

OK.
Well, I did a git pull this morning. So maybe someone already corrected this.

comment:13 Changed 4 years ago by slyfox

  • Votes for changeset changed from andrew_b to andrew_b slyfox
  • Branch state changed from on review to approved

comment:14 Changed 4 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b slyfox to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

Merged to master:

git log --pretty=oneline d235c71..a2a01d9

comment:15 Changed 4 years ago by slavazanko

  • Status changed from testing to closed
  • Keywords stable-candidate removed
  • Votes for changeset changed from committed-master to committed-master committed-stable

Merged to stable:

git log --pretty=oneline dca2d82..15a9a74
Note: See TracTickets for help on using tickets.