Ticket #2248 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Upon creation of a new file, the translation is not set in mcedit (=> input = unprintable chars)

Reported by: zaytsev Owned by: andrew_b
Priority: major Milestone: 4.7.3
Component: mcedit Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master committed-stable

Description (last modified by andrew_b) (diff)

Forwarded from Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=586903

If I create new file with Shift+F4 and start to type text in it, mcedit will
show dots instead of letters. I didn't change any preferences since previous
version in Squeeze. In the previuos version it worked fine.

"Previous" here refers to 4.7.0. Reproducible on 4.7.0.6 and 4.7.3. Upon setting the translation with Alt+e to "no translation" everything starts working fine.
Should be a trivial fix for an uninitialized variable or something like that.
Thanks!

Change History

comment:1 in reply to: ↑ description Changed 6 years ago by andrew_b

Replying to zaytsev:

Reproducible on 4.7.0.6 and 4.7.3.

4.7.3 is not released yet. Personally me cannot reproduce that in KOI8-R and UTF-8 locale on current master.

comment:2 Changed 6 years ago by andrew_b

4.7.0.6 also works fine for me.

comment:3 follow-up: ↓ 4 Changed 6 years ago by zaytsev

I meant the current master of course. I have completely UTF-8 system. I am gonna test on a Redhat system right now, to make sure it's not a Debian specific issue.

It's well known that you can hardly reproduce such issues because of your single-byte setup.

comment:4 in reply to: ↑ 3 Changed 6 years ago by andrew_b

Replying to zaytsev:

It's well known that you can hardly reproduce such issues because of your single-byte setup.

I can test user account with UTF-8 locale for such cases.

comment:5 Changed 6 years ago by zaytsev

Still you were not able to reproduce things in the past, right? I can reproduce it on RHEL 5 / mc 4.7.0.6 / ncurses (Debian uses SLang).

Any thoughts?

comment:6 Changed 6 years ago by zaytsev

Ilia: I've just tested latest master. It's broken at the moment.

comment:7 Changed 6 years ago by angel_il

  • Owner set to angel_il
  • Status changed from new to accepted

comment:8 Changed 6 years ago by andrew_b

  • Owner changed from angel_il to andrew_b
  • severity changed from no branch to on review

Created 2248_editor_set_codeset_fix branch. Parent branch is master.
changeset:9dfe1ed0703ab2b933c3d41ce0a9a4c6b2205ac7

comment:9 Changed 6 years ago by andrew_b

  • Keywords stable-candidate added

comment:10 Changed 6 years ago by angel_il

  • Votes for changeset set to angel_il

comment:11 Changed 6 years ago by slavazanko

  • Votes for changeset changed from angel_il to angel_il slavazanko
  • severity changed from on review to approved

comment:12 Changed 6 years ago by andrew_b

  • Keywords stable-candidate removed
  • Status changed from accepted to testing
  • Votes for changeset changed from angel_il slavazanko to committed-master committed-stable
  • Resolution set to fixed
  • severity changed from approved to merged

comment:13 Changed 6 years ago by andrew_b

  • Status changed from testing to closed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.