Ticket #1863 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

fixing in seventeen files some memory alloc-calls

Reported by: vit_r Owned by: vit_r
Priority: major Milestone: 4.7
Component: mc-core Version: 4.7.0-pre4
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by andrew_b) (diff)

Logical design:

if [ g_Xalloc(which failing does _NOT_ return NULL) ]; then

    If (retval _IS_ checked); then

        g_Xalloc is replaced by g_try_Xalloc(failing returns NULL)

    fi

elif [ Xalloc(failing returns NULL) ]; then

    If (retval is _NOT_ checked); then

        Xalloc is replaced by g_Xalloc(failing aborts)

    fi

fi

Attachments

1863-fixing-some-memory-alloc-calls.patch (17.8 KB) - added by vit_r 7 years ago.
fixing in seventeen files some memory alloc-calls

Change History

Changed 7 years ago by vit_r

fixing in seventeen files some memory alloc-calls

comment:1 Changed 7 years ago by vit_r

  • Owner set to vit_r
  • Status changed from new to assigned

comment:2 follow-up: ↓ 3 Changed 7 years ago by andrew_b

  • Status changed from assigned to testing
  • Resolution set to duplicate
  • Description modified (diff)

Closed as duplicate of #1857.

comment:3 in reply to: ↑ 2 Changed 7 years ago by vit_r

Replying to andrew_b:

Closed as duplicate of #1857.

Property  resolution changed from  to duplicate

Please:
1.

From what "Property resolution" is changed ?

2.

Is it possible to remove or at least to close #1857 and to leave this #1863 instead ?
Because there is no an option to move a patch i've emptied that file.



comment:4 Changed 7 years ago by andrew_b

  • Status changed from testing to closed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.