Ticket #43 (reopened defect)

Opened 8 years ago

Last modified 5 months ago

savannah: [ENHANCEMENT] MC is slow when working with lots of files

Reported by: lzap Owned by:
Priority: major Milestone: Future Releases
Component: mc-core Version: master
Keywords: Cc: egmont@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by ossi) (diff)

Original: http://savannah.gnu.org/bugs/?16256

Submitted by:Lukas Zapletal <lzap>Submitted on:Mon 03 Apr 2006 07:43:30 PM UTC
Category:CoreSeverity:3 - Normal
Status:NonePrivacy:Public
Assigned to:NoneOpen/Closed:Open
Release:All versionsOperating System:GNU/Linux

Original submission:

When you copy/remove lots of files, the midnight gets too slow 
because of thousands of screen redraws (per a second). Terminals 
are slow and disc is waiting.

It would be nice to limit the redraw of the copy/remove window do 
an user defined time (e.g. 200-500 ms). This could be easy to 
implement (and you dont need threads or something like that - just 
one "if" and time measurement).

Check this out - touch 100000 files and try to delete with midnight 
and after that with the "rm" command. Feel the difference?

Change History

comment:1 Changed 7 years ago by styx

  • Milestone set to future releases

comment:2 Changed 7 years ago by angel_il

  • Status changed from new to closed
  • Resolution set to wontfix
  • severity set to no branch

hmm... works quickly

comment:4 Changed 5 years ago by sorin

  • Branch state set to no branch

Why wontfix? Curently removing lots of files in mc takes minutes and with "rm -rf" only 1-2 seconds.

comment:5 Changed 5 years ago by slavazanko

If you have suggestions and patches - feel free to reopen this ticket.

comment:6 Changed 5 years ago by ossi

mc has a "verbose operation" option which enables progress output in the first place.

but the idea to implement event compression (repaint skipping) is entirely reasonable - nobody can follow more than five filenames per second anyway. so just omit progress updates if less then 200ms passed from the previous update.

comment:7 Changed 5 years ago by angel_il

i think it's good idea..

comment:8 Changed 2 years ago by ossi

  • Description modified (diff)
  • Reporter changed from slavazanko to lzap

comment:9 Changed 2 years ago by andrew_b

  • Status changed from closed to reopened
  • Version set to master
  • Resolution wontfix deleted
  • Milestone changed from future releases to Future Releases

comment:10 Changed 2 years ago by andrew_b

Ticket #3028 has been marked as a duplicate of this ticket.

comment:11 Changed 2 years ago by andrew_b

Ticket #3218 has been marked as a duplicate of this ticket.

comment:12 Changed 2 years ago by DvanDellen

Disable verbose in the options doesn't make that much difference, actually takes more time to copy +-7GB
Any tips? Is this fixed in a newer version?(current 4.8.3)

comment:13 Changed 22 months ago by egmont

Could this be related to #3247 (incl. its comment 3)? I'm afraid even in non-verbose mode mc just does way too many screen updates (prints every filename in the dialog), probably rate limiting them would noticeably speed up the actual operation.

comment:14 Changed 22 months ago by egmont

  • Cc egmont@… added

comment:15 Changed 5 months ago by andrew_b

  • Component changed from mc-vfs to mc-core
Note: See TracTickets for help on using tickets.