Ticket #301 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Syntax rules for SmallTalk inside "ml.syntax"

Reported by: crlf Owned by: styx
Priority: trivial Milestone: 4.7
Component: mcedit Version: 4.6.2
Keywords: commited-master Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

The syntax file for "ML" also includes syntax rules for SmallTalk?.

Change History

comment:1 Changed 7 years ago by angel_il

To crlf,
mc allready have ml.syntax (CamlLight?) and smalltalk.syntax (SmallTalk?).
That do you mean? give more information about this ticket.

comment:2 Changed 7 years ago by crlf

It's like I said, although there is a separate "smalltalk.syntax" file, the "ml.syntax" file contains a duplicate of the smalltalk rules starting at line 98.

http://www.midnight-commander.org/browser/syntax/ml.syntax

It's a minor thing, but it's funny since this was something that seems to come from Cooledit. If I remember correctly, when I submitted these rules Cooledit had a single file for all rules. When they were split up, this also happened.

I was never a Midnight Commander user, actually, but I remembered that it shared syntax rules with Cooledit and when I found it was still being maintained, I just got curious to browse the source.

comment:3 Changed 7 years ago by angel_il

ok :) now i see this :) thx

comment:4 Changed 7 years ago by styx

  • Status changed from new to accepted
  • Owner set to styx

comment:5 Changed 7 years ago by styx

branch: 301_rem_sml_from_ml 2b21e44aa14de77e5b4c1ec83304638a5bb5bdc5

comment:6 Changed 7 years ago by slyfox

  • Keywords vote-slyfox added

I noticed it too some time ago. Removal looks good.
My vote!

comment:7 Changed 7 years ago by angel_il

  • Keywords vote-angel_il added

comment:8 Changed 7 years ago by styx

  • Keywords approved added

comment:9 Changed 7 years ago by styx

  • Status changed from accepted to testing
  • Keywords commited-master added; vote-slyfox vote-angel_il approved removed
  • Resolution set to fixed

comment:10 Changed 7 years ago by styx

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.