Ticket #2816 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

After uploading to FTP mc stops being able to navigate inside of FTP

Reported by: alex18 Owned by:
Priority: minor Milestone: Future Releases
Component: mc-vfs Version: 4.8.3
Keywords: ftp Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:


GNU Midnight Commander 4.8.3
Built with GLib 2.32.1
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Root directory: /home/alex

[System data]

Config directory: /etc/mc/
Data directory: /usr/share/mc/
VFS plugins and scripts: /usr/lib/mc/

extfs.d: /usr/lib/mc/extfs.d/
fish: /usr/lib/mc/fish/

[User data]

Config directory: /home/alex/.config/mc/
Data directory: /home/alex/.local/share/mc/

skins: /home/alex/.local/share/mc/skins/
extfs.d: /home/alex/.local/share/mc/extfs.d/
fish: /home/alex/.local/share/mc/fish/

Cache directory: /home/alex/.cache/mc/

$ mc --configure-options

'--prefix=/usr' '--sysconfdir=/etc' '--mandir=/usr/share/man' '--enable-background' '--enable-charset' '--enable-largefile' '--with-edit' '--with-gpm-mouse' '--with-mmap' '--enable-vfs-smb' '--with-screen=slang' '--with-subshell' '--with-vfs' '--with-x' '--without-debug' '--without-gnome' '--without-included-gettext' '--libexecdir=/usr/lib' 'CFLAGS=-march=i686 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2' 'LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu'

Steps to face the issue:

  1. Start mc
  2. Go to some FTP server by executing command like "cd ftp://user:password@ftp.server.com"
  3. Right after you logged onto the FTP server go a couple dirs in depth
  4. Select several files and dirs with files and subdirs(!) in the second mc panel and copy them to FTP server with F5 (files should go to subdirs of FTP because we moved a little bit in depth before)
  5. After copying is complete - refresh (Ctrl+R) and try to navigate in FTP a little bit (go deeper and upper in FTP filesystem)

What is the expected output?

Correct navigation.

What do you see instead?

No navigation but an error: cannot change the directory.

Change History

comment:1 Changed 4 years ago by andrew_b

Seems this is already fixed in #2800.

comment:2 Changed 4 years ago by andrew_b

  • Component changed from mc-core to mc-vfs

comment:3 Changed 4 years ago by slavazanko

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2800. Just another appearance of the same bug.

comment:4 Changed 4 years ago by alex18

When will 4.8.4 come out?

Note: See TracTickets for help on using tickets.