Ticket #2783 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

directories opening in the wrong panel

Reported by: tempUser Owned by: andrew_b
Priority: major Milestone: 4.8.4
Component: mc-core Version: 4.8.3
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

$ mc --help

mc [OPTION...] [+number] [this_dir] [other_panel_dir]

According to this, if i do, say

$ mc / /tmp

/ should open in the left pane, and /tmp should open in the right pane. But with the latest version, they are opening in the opposite panes, i.e., the one which should open in the left pane is opening in the right, and vice versa.

$ LC_MESSAGES=C mc -V

GNU Midnight Commander 4.8.3
Built with GLib 2.30.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

$ mc --configure-options

'--prefix=/usr' '--sysconfdir=/etc' '--mandir=/usr/share/man' '--enable-background' '--enable-charset' '--enable-largefile' '--with-edit' '--with-gpm-mouse' '--with-mmap' '--enable-vfs-smb' '--with-screen=slang' '--with-subshell' '--with-vfs' '--with-x' '--without-debug' '--without-gnome' '--without-included-gettext' '--libexecdir=/usr/lib' 'CFLAGS=-march=i686 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2' 'LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu'

Attachments

mc_panels.ini.diff (915 bytes) - added by tempUser 5 years ago.

Change History

comment:1 Changed 5 years ago by andrew_b

Cannot confirm. Works as expected for me.

comment:2 Changed 5 years ago by angel_il

i can't reproduce...

Changed 5 years ago by tempUser

comment:3 Changed 5 years ago by tempUser

Hmm.. i backed up panels.ini, and launched mc again, and this time it worked fine. Seems like a setting there was causing this problem.

I have attached a diff file, showing the difference between the previous panels.ini file, and a fresh one.

comment:4 Changed 5 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Milestone changed from Future Releases to 4.8.4

Thanks!

@@ -28,5 +28,5 @@ user_status3=half type name | size | per
 user_mini_status=0
 
 [Dirs]
-current_is_left=0
-other_dir=/home/user
+current_is_left=1
+other_dir=/home/user/downloads

current_is_left is the main difference. First argument is applied to the current panel, but should to left one.

comment:5 Changed 5 years ago by andrew_b

  • Keywords stable-candidate added
  • Branch state changed from no branch to on review

Branch: 2783_dir_panel_order (parent: master).
changeset:eb5f9e05432b3adab980ab4a4778992e11b299e3

comment:6 Changed 5 years ago by angel_il

  • Votes for changeset set to angel_il

comment:7 Changed 5 years ago by slavazanko

  • Votes for changeset changed from angel_il to angel_il slavazanko
  • Branch state changed from on review to approved

comment:8 Changed 5 years ago by andrew_b

  • Keywords stable-candidate removed
  • Status changed from accepted to testing
  • Votes for changeset changed from angel_il slavazanko to committed-master committed-stable
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:9 Changed 5 years ago by andrew_b

  • Status changed from testing to closed
  • Summary changed from directories opening in the wrong pane to directories opening in the wrong panel

comment:10 Changed 5 years ago by andrew_b

  • Status changed from closed to reopened
  • Votes for changeset committed-master committed-stable deleted
  • Resolution fixed deleted
  • Branch state changed from merged to no branch

When right panel is active, panel paths are swapped at each mc start.

How to reproduce.

1. Goto ~. Run mc. Enable autosave panels setup before exit. Save options.
2. Open ~ dir in the left panel, / in the right one. Make right panel active.
3. Close mc.
4. With mc-wrapper, following is performed:
4.1. Run mc. Now ~ in the right panel, / in the left one.
4.2. Close mc.
4.3. Run mc. Now ~ in the left panel again, / in the right one.
4.x. and so on.
5. Without mc-wrapper, following is performed:
5.1. Run mc. Now ~ in both panels.

Expected behavior with current_is_left=false

  1. if mc start as mc dir dir2, dir1 is opened in the left panel, dir2 in the right one.
  2. if mc starts as mc (without dir1 and dir2), active (right) panel contains working directory, other (left) one contains other_dir from panel.ini.
  3. if mc start as mc dir1, dir1 is opened in the left panel, right panel contains working directory.
Version 0, edited 5 years ago by andrew_b (next)

comment:11 Changed 5 years ago by andrew_b

  • Keywords stable-candidate added
  • Branch state changed from no branch to on review

Branch: 2783_panel_dir_fix (parent: master).
changeset:0db03f65703010ae0d518391eff2f47b49fd4b7e

comment:12 Changed 5 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:13 Changed 5 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • Branch state changed from on review to approved

comment:14 Changed 5 years ago by andrew_b

  • Keywords stable-candidate removed
  • Status changed from reopened to closed
  • Votes for changeset changed from slavazanko angel_il to committed-master committed-stable
  • Resolution set to fixed
  • Branch state changed from approved to merged
Note: See TracTickets for help on using tickets.