Ticket #2736 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

MC deletes the wrong file

Reported by: nfl Owned by: andrew_b
Priority: major Milestone: 4.8.2
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

Based on https://bugs.launchpad.net/ubuntu/+source/mc/+bug/897942:

What version of Midnight Commander is used?
4.8.1

What steps will reproduce the problem?
1, Switch off delete confirmation.
2, Go to a directory with two files: "junk" and "vital".
3, Outside MC, delete "junk".
4, In MC, press F8 on "junk".

What is the expected output?
MC presents some error message that "junk" does not exist.

What do you see instead?
MC deletes "vital".

If you enable delete confirmation then MC asks if you want to delete "vital", but people don't expect such a tricky question.

Change History

comment:1 Changed 5 years ago by andrew_b

  • Keywords stable-candidate added
  • Status changed from new to accepted
  • Owner set to andrew_b
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.2

Branch: 2736_dont_panel_reload (parent: master).
changeset:19528d71030e0daddb9376d6a0d834a6c030af25

comment:2 Changed 5 years ago by angel_il

  • Votes for changeset set to angel_il

comment:3 Changed 5 years ago by slavazanko

  • Votes for changeset changed from angel_il to angel_il slavazanko
  • Branch state changed from on review to approved

comment:4 Changed 5 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from angel_il slavazanko to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:5 Changed 5 years ago by egmont

This seems to be a quite serious bug. Could you guys please backport this patch to the soon-to-be-stable 4.8.1 branch? Thanks a lot!

comment:6 Changed 5 years ago by slavazanko

Of course, patch will be applied to stable branch in any way. This ticket have keyword 'stable candidate'; this mean, before next stable release we will search tickets by this keyword and will apply all patches to stable branch (also, ticket will change state to 'closed' from 'testing').

Last edited 5 years ago by slavazanko (previous) (diff)

comment:7 Changed 5 years ago by egmont

Thanks for the clarification, I didn't notice there was such a 'stable candidate' keyword in this bugtracker.

Last edited 5 years ago by slavazanko (previous) (diff)

comment:8 Changed 5 years ago by slavazanko

  • Status changed from testing to closed
  • Keywords stable-candidate removed

comment:9 Changed 5 years ago by slavazanko

  • Votes for changeset changed from committed-master to committed-master committed-stable
Note: See TracTickets for help on using tickets.