Ticket #2711 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 months ago

Crash in file search

Reported by: akorop Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.1
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by zaytsev) (diff)

mc crash in file search for content if "Whole words" is marked. Failure occurs after at least one file is found. System - ubuntu 10.04, WM - openbox.
At me, this bug present in few latest versions, including 4.8.1. This bug NOT present in the 4.7.0 from Ubuntu repository.

Stack dump:

Program received signal SIGSEGV, Segmentation fault.
0xb7c46281 in _pcre_xclass () from /lib/libpcre.so.3
(gdb) bt 
#0  0xb7c46281 in _pcre_xclass () from /lib/libpcre.so.3
#1  0xb7c3bc3f in ?? () from /lib/libpcre.so.3
#2  0xb7c3b50a in ?? () from /lib/libpcre.so.3
#3  0xb7c43fae in pcre_exec () from /lib/libpcre.so.3
#4  0xb7e48ca4 in g_match_info_next () from /lib/libglib-2.0.so.0
#5  0xb7e48e89 in g_regex_match_full () from /lib/libglib-2.0.so.0
#6  0x080a8c33 in mc_search__regex_found_cond_one (lc_mc_search=0x8215830, 
    user_data=0x8214758, start_search=0, end_search=16, found_len=0xbfffdcd8)
    at regex.c:262
#7  mc_search__regex_found_cond (lc_mc_search=0x8215830, user_data=0x8214758, 
    start_search=0, end_search=16, found_len=0xbfffdcd8) at regex.c:309
#8  mc_search__run_regex (lc_mc_search=0x8215830, user_data=0x8214758, start_search=0, 
    end_search=16, found_len=0xbfffdcd8) at regex.c:838
#9  0x080a7899 in mc_search__run_normal (lc_mc_search=0x8215830, user_data=0x8214758, 
    start_search=0, end_search=16, found_len=0xbfffdcd8) at normal.c:114
#10 0x08097040 in mc_search_run (lc_mc_search=0x8215830, user_data=0x8214758, 
    start_search=0, end_search=16, found_len=0xbfffdcd8) at search.c:266
#11 0x080bcbee in search_content (h=<value optimized out>, 
    directory=<value optimized out>, filename=0x8205783 ".esd_auth") at find.c:1031
#12 0x080bd20c in do_search (h=0x8214f10) at find.c:1293
#13 0x080bd35d in find_callback (h=0x3, sender=0x0, msg=136398944, parm=136398945, 
    data=0x0) at find.c:1390
#14 0x0808ec6f in frontend_run_dlg (h=0x8214f10) at dialog.c:544
#15 run_dlg (h=0x8214f10) at dialog.c:1158
#16 0x080bedfa in run_process () at find.c:1553
#17 do_find () at find.c:1594
#18 find_file () at find.c:1726
#19 0x080ae937 in find_cmd () at cmd.c:987
#20 0x080c686a in midnight_execute_cmd (sender=0x0, command=136398944) at midnight.c:1154
#21 0x0808e7f2 in dlg_key_event (h=0x81f4900, key=8255, event=0xbffff300) at dialog.c:508
#22 dlg_process_event (h=0x81f4900, key=8255, event=0xbffff300) at dialog.c:1126
#23 0x0808ecba in frontend_run_dlg (h=0x81f4900) at dialog.c:557
#24 run_dlg (h=0x81f4900) at dialog.c:1158
#25 0x080c878c in create_panels_and_run_mc () at midnight.c:904
#26 0x080c899d in do_nc () at midnight.c:1660
#27 0x0805861b in main (argc=1, argv=0xbffff564) at main.c:516

Change History

comment:1 Changed 4 years ago by andrew_b

  • Version changed from 4.7.5.6 to 4.8.1

comment:2 follow-up: ↓ 3 Changed 4 years ago by andrew_b

What glib versions mc is built and run with?

comment:3 in reply to: ↑ 2 Changed 4 years ago by akorop

Replying to andrew_b:

What glib versions mc is built and run with?

ubuntu 10.04
libglib2.0-0 version 2.24.1-0ubuntu1

comment:4 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to worksforme

Such bug was never occurred for me. I'm unable to reproduce it. Please ask your mc maintainer to play with various versions of glib2 and pcre.

comment:5 Changed 4 months ago by zaytsev

  • Description modified (diff)

comment:6 Changed 4 months ago by zaytsev

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.