Ticket #2608 (closed enhancement: fixed)

Opened 5 years ago

Last modified 4 years ago

Widget enhancement

Reported by: andrew_b Owned by: andrew_b
Priority: major Milestone: 4.8.3
Component: mc-core Version: 4.8.2
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

As a part of #2261, some enhancements of widgets are required:

  • dynamically add and remove widgets to/form dialog in runtime
  • reordering widgets in in dialog
  • handling of overlapped widgets
  • etc

Change History

comment:1 Changed 4 years ago by andrew_b

  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.2

Branch: 2608_widget_enhancement (parent: master).
Initial changeset:ff588a1bf92571bfee8a362957d89109a099d2fb

comment:2 Changed 4 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:3 follow-up: ↓ 4 Changed 4 years ago by angel_il

please squash commits, and rebase branch

comment:4 in reply to: ↑ 3 Changed 4 years ago by andrew_b

Replying to angel_il:

please squash commits, and rebase branch

Done: [0c4ea42429641df59969500a5bb6c0e9d1ae6e53]

comment:5 Changed 4 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il

comment:6 Changed 4 years ago by angel_il

  • Branch state changed from on review to approved

comment:7 Changed 4 years ago by angel_il

  • Votes for changeset slavazanko angel_il deleted
  • Branch state changed from approved to on rework

STOP!

comment:8 Changed 4 years ago by slavazanko

Explain your think a little bit more, please.

comment:9 Changed 4 years ago by slavazanko

  • Blocked By 2695 added

(In #2695) Have bug with branch:

  • run mc
  • press Shift-F4 (create new file in editor)
  • type any char

segfault here

comment:10 Changed 4 years ago by slavazanko

  • Branch state changed from on rework to approved

bug isn't related to this ticket, therefore branch state restored to 'approved', but branch still blocked until bug in #2695 resolved.

comment:11 Changed 4 years ago by angel_il

  • Votes for changeset set to slavazanko angel_il

comment:12 Changed 4 years ago by andrew_b

  • Blocked By 2695 removed

comment:13 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Votes for changeset changed from slavazanko angel_il to committed-master
  • Resolution set to fixed
  • Blocking 2261 removed
  • Branch state changed from approved to merged

Merged to master: [dba17c8fde6205d94c78c557aaf4e0e4c2e4da8b]

git log --pretty=oneline 8fe49bb..dba17c8

comment:14 Changed 4 years ago by andrew_b

  • Status changed from closed to reopened
  • Votes for changeset committed-master deleted
  • Version changed from master to 4.8.2
  • Branch state changed from merged to no branch
  • Milestone changed from 4.8.2 to 4.8.3
  • Resolution fixed deleted

Because of [6ad4b2466b97d33e8f865b68e43082969c9c1e3a] mc hangs while switching to opened screen.

How to reproduce:

  1. run mc
  2. open any file in the internal editor (press f4)
  3. Switch to the file managed (press alt-`, select panels and press enter)
  4. Switch to the opened editor (press alt-`, select editor and press enter)
  5. mc hangs

comment:15 Changed 4 years ago by andrew_b

  • Type changed from enhancement to defect
  • Branch state changed from no branch to on review

Branch: 2608_switch_screen_hang (parent: master).
changeset:d971ab8d1e351b173d151c622bfde2f72f8b3ce0

comment:16 Changed 4 years ago by angel_il

  • Votes for changeset set to angel_il

comment:17 Changed 4 years ago by slavazanko

  • Votes for changeset changed from angel_il to angel_il slavazanko
  • Branch state changed from on review to approved

comment:18 Changed 4 years ago by andrew_b

  • Status changed from reopened to closed
  • Votes for changeset changed from angel_il slavazanko to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:19 Changed 4 years ago by andrew_b

  • Type changed from defect to enhancement

comment:20 Changed 4 years ago by andrew_b

Version 0, edited 4 years ago by andrew_b (next)
Note: See TracTickets for help on using tickets.