Ticket #2593 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

"Hint" line jumps to the top of the screen and overwrites main menu

Reported by: sergem Owned by: andrew_b
Priority: major Milestone: 4.8.0-pre2
Component: mc-core Version: 4.8.0-pre1
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description (last modified by andrew_b) (diff)

Problem


"Hint" line jumps to the top of the screen and overwrites main menu

Steps to reproduce


  1. Run mc. See the "Hint" line near the command line as usual. Put the cursor on any file or folder.
  2. Press F8, see a confirmation box.
  3. Press Esc (two times) to avoid file deletion.
  4. That's all. The "Hint" line's jumped up. If it's not - goto 1.

I reproduced it 5 times with no more than 3 tries.

Change History

comment:1 Changed 5 years ago by andrew_b

  • Description modified (diff)
  • Summary changed from "Hint" line jumps to the top of the window and overwrite title to "Hint" line jumps to the top of the screen and overwrites main menu

comment:2 follow-up: ↓ 3 Changed 5 years ago by andrew_b

An attached patch fixes the bug. But extra test is required to avoid potential regression in file operations.

comment:3 in reply to: ↑ 2 Changed 5 years ago by andrew_b

Patch was removed because it produced segfault. Sorry...

comment:4 Changed 5 years ago by andrew_b

  • Owner set to andrew_b
  • Keywords stable-candidate added; hint removed
  • Status changed from new to accepted
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.0-pre2

Branch: 2593_hintbar (parent: master).
Initial changeset:bfa147d745c93cfe76282d331a38691a02288dad

comment:5 Changed 5 years ago by angel_il

  • Votes for changeset set to angel_il

comment:6 Changed 5 years ago by slavazanko

  • Keywords hintbar added
  • Votes for changeset changed from angel_il to angel_il slavazanko
  • Branch state changed from on review to approved

comment:7 Changed 5 years ago by andrew_b

  • Status changed from accepted to testing
  • Keywords hintbar removed
  • Votes for changeset changed from angel_il slavazanko to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

Merged to master.
changeset:bf3dafba01ca020cd110dc8f63aa2131b4aa260c

git log --pretty=oneline eb13abc..bf3dafb

comment:8 Changed 5 years ago by andrew_b

  • Keywords stable-candidate removed
  • Status changed from testing to closed
  • Votes for changeset changed from committed-master to committed-master committed-stable

Cherry-picked to stable.
Initial changeset:d434ea4cc4faf5bbc792a4954301cd0435e17652

Note: See TracTickets for help on using tickets.