Ticket #2574 (closed defect: wontfix)

Opened 5 years ago

Last modified 5 years ago

symlink loop in .deb segfaults mc

Reported by: helix84 Owned by:
Priority: major Milestone:
Component: mc-vfs Version: 4.7.0.6
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When browsing a .deb file with an infinite direcotry symlink loop, mc crashes when trying to enter the directory.

Link to example file:

http://ftp.us.debian.org/debian/pool/main/i/iceowl-l10n/iceowl-l10n-vi_1.0~b2-1_all.deb

Steps to reproduce:

1) Download the example file
2) in mc, go to "iceowl-l10n-vi_1.0~b2-1_all.deb#deb/CONTENTS/usr/lib/icedove"
3) After entering the "extensions" directory, mc crashes with "Segmentation fault"

Change History

comment:1 Changed 5 years ago by angel_il

i try 4.7.0.6 and 4.8.0-pre2-9-g1e9a3f5

under 'karmic'
i can't reproduce this...

please attache crash log for more info... see https://www.midnight-commander.org/wiki/doc/tracingCrash

comment:2 Changed 5 years ago by IceMan

I check this issue with mc 4.8.1-38-g144824c - working as expected.

comment:3 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to wontfix
  • Milestone Future Releases deleted

OK.
Closed as WONTFIX for 4.7.0.x.

Note: See TracTickets for help on using tickets.