Ticket #2475 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

mc segfaults on start

Reported by: gorsa Owned by: andrew_b
Priority: critical Milestone: 4.8.0-pre1
Component: mc-skin Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Segfault at start with latest git version:
$gdb mc
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
(gdb) run
Starting program: /usr/bin/mc

Program received signal SIGSEGV, Segmentation fault.
0xb7ce625b in strlen () from /lib/tls/i686/cmov/libc.so.6
(gdb) backtrace
#0 0xb7ce625b in strlen () from /lib/tls/i686/cmov/libc.so.6
#1 0xb7cb5812 in vfprintf () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7cd68ec in vasprintf () from /lib/tls/i686/cmov/libc.so.6
#3 0xb7e2ec17 in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#4 0xb7e1bc06 in g_strdup_vprintf () from /usr/lib/libglib-2.0.so.0
#5 0xb7e1bc2b in g_strdup_printf () from /usr/lib/libglib-2.0.so.0
#6 0x08097ec7 in mc_skin_colors_old_configure_one (mc_skin=0x813780c, the_color_string=<value optimized out>) at colors-old.c:169
#7 0x08098019 in mc_skin_colors_old_configure (mc_skin=0x813780c) at colors-old.c:190
#8 0x0807d3d9 in mc_skin_init (error=0xbfdbb344) at common.c:132
#9 0x080579db in main (argc=1, argv=Cannot access memory at address 0x5
) at main.c:489
(gdb) quit

Change History

comment:1 Changed 5 years ago by andrew_b

  • Priority changed from major to critical

Please show the [Colors] section in your ~/.config/mc/ini file.

comment:2 Changed 5 years ago by gorsa

[Colors]
base_color=linux:normal=white,black:marked=,black:input=,green:menu=black:menusel=white:menuhot=red,:menuhotsel=black,red:dfocus=white,black:dhotnormal=white,black:dhotfocus=white,black:executable=,black:directory=white,black:link=white,black:device=white,black:special=white,black:core=,black:stalelink=red,black:editnormal=white,black
xterm=
color_terminals=

rxvt-unicode=

screen=

After I delete the ~/.config/mc/ folder, mc re-creates it and starts successfully. Looks like the problem is solved. Thank you.

comment:3 Changed 5 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Component changed from mc-core to mc-skin
  • Milestone changed from 4.8 to 4.8.0-pre1

Thanks, you found a bug in color string parser. This bug was introduced in 265-colors support.

comment:4 Changed 5 years ago by andrew_b

  • Blocked By 2169 added

comment:5 Changed 5 years ago by egmont

Oops, sorry, my bad. Thanks andrew_b for the fix!

comment:6 Changed 5 years ago by slavazanko

  • Blocked By 2169 removed

(In #2169) merge changeset:6ab2753063c3f538fd6a545681873445ea10156f

[code]
git log --pretty=oneline 1b99570..0f2578d
code

comment:7 Changed 5 years ago by andrew_b

  • Status changed from accepted to testing
  • Resolution set to fixed
  • severity changed from no branch to merged

comment:8 Changed 5 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.