Ticket #2425 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

4.7.0.10 segfaults on NetBSD>=3.0 on startup

Reported by: cheusov Owned by: andrew_b
Priority: critical Milestone: 4.7.5
Component: mc-core Version: 4.7.0.10
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description

mc-4.7.0.10 segfaults on NetBSD 3.0 and above.
The problem is in mountlist.c:read_filesystem_list function.
Have a look at line 409. Here

me->me_next = NULL;

is missed. It should be there in order to correctly
create a list, just like in

#ifdef MOUNTED_GETMNTINFO
...
#endif

section for 44BSD and derivates.
Working patch is in attachment.
I also have cleaned up the source code
a little bit by removing copy/paste.

Attachments

mc.patch (1.8 KB) - added by cheusov 6 years ago.

Change History

Changed 6 years ago by cheusov

comment:1 Changed 6 years ago by andrew_b

  • Votes for changeset set to andrew_b
  • severity changed from no branch to on review
  • Milestone changed from Future Releases to 4.7.5

4.7.0.10 is the last release in 4.7.0.x series. Next stable release will have the 4.7.5 codebase. This patch is applied to master branch and 4.7.5 relese will contain it.

Created 2425_netbsd_mountlist_fixup branch. Parent branch is master,
changeset:faff5709c69e1f02da5da33f516217e0120da29c

Since cheusov is the author of the patch, my vote here.

comment:2 Changed 6 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted

comment:3 Changed 6 years ago by angel_il

  • Votes for changeset changed from andrew_b to andrew_b angel_il
  • severity changed from on review to approved

comment:4 Changed 6 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b angel_il to committed-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:5 Changed 6 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.