Ticket #2377 (closed enhancement: wontfix)

Opened 6 years ago

Last modified 6 years ago

copy/move dialog: update speed rate

Reported by: x905 Owned by:
Priority: trivial Milestone:
Component: mc-core Version:
Keywords: Cc: gotar@…
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

need to update speed indicator in copy/move dialog more frequently (10+ times per second) to more precisely see current transfer speed

this may be usefull to detect speed failures on network or disks

Change History

comment:1 Changed 6 years ago by masics

Did you thought about using MC over slow connections?

comment:2 Changed 6 years ago by gotar

  • Priority changed from major to trivial
  • Cc gotar@… added
  • Type changed from defect to enhancement

No, no and no. This is so stupid I'd like to leave it without comment...

No network gives you 100 ms throughput failures anyone should care, not using TCP. If you want to detect these, just use specialized network tools based on ICMP or UDP.

100 MB/s gives only 10 MB/100 ms during which disk may be busy doing some other stuff.

It's another ticket where you just want to see numbers changing. Run bwm-ng with 100 ms interval.

comment:3 follow-up: ↓ 4 Changed 6 years ago by x905

now indicator updates so slowly (i think 1 time per 3 seconds), so it useless as indicator
then i see "numbers changing" - i do some conclusions about how my system works

comment:4 in reply to: ↑ 3 Changed 6 years ago by gotar

Current indicator makes sense for larger operations only, that's true. However it's not so obvious _what_ should it measure. There are at least 3 options:

  1. average since the beginning of a transmission,
  2. moving average from last n seconds (or weighted moving average or exponential moving average, triangular moving average etc.),
  3. current speed (e.g. in timeslot since last calculation).

Ad 1. this should give the best results for bursty network transmissions,
Ad 2. this would compute best ETA _provided_ keeping current conditions (e.g. network/disk usage).
Ad 3. this makes no sense for short timeslots. With longer it converges to (simple) moving average - see 2.

As far as I understand you want to see current speed with 100 ms intervals (3) - once again, it doesn't make ANY sense. Unless you run mc on real-time system or DOS.

comment:5 in reply to: ↑ description Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.4 deleted
  • Resolution set to wontfix
  • Milestone 4.7 deleted

Replying to x905:

need to update speed indicator in copy/move dialog more frequently (10+ times per second)

You are proposing to make mc more slower and slower again. Currently, the MC copy and move operations are slower than cp and mv programs. I'd say, dramatically slower... Each extra updating and screen repainting will increase the total time of copy/move operations.

Sorry, but closed as wontfix.

comment:6 Changed 6 years ago by x905

if updating screen will increase the total time of copy/move operations - this is realy bad design of copy/move procedure
i performed tests with 'cp' and 'pv' and see no regression of speed

Note: See TracTickets for help on using tickets.