Ticket #2330 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Some non-alpha chars are ignored during case-insensitive file sorting

Reported by: wayfarer Owned by:
Priority: minor Milestone:
Component: mc-core Version:
Keywords: file sorting Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

When using case-sensitive sorting, special chars like "." or "!" are considered to be less than any letter/digit, which is right. Eg:

/!config
/.config
/Downloads
/config

However, when switching to case-insensitive sorting, these chars seems to be just ignored. Eg:

/config
/!config
/.config
/Downloads

which is is not a correct sorting order, I suppose.

Change History

comment:1 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.3 deleted
  • Resolution set to duplicate

Duplicate of #1894 and #1978. Please use search before create ticket.

comment:2 Changed 6 years ago by wayfarer

Sorry, haven't found them.

Note: See TracTickets for help on using tickets.