Ticket #2298 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

mc doesn't create .mc folder for saving settings

Reported by: valentt Owned by:
Priority: major Milestone:
Component: mc-core Version:
Keywords: Cc: zaytsev
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

I have been scratching my head for some time now and finally I found what is the issue.

Here are the steps I did:

  1. install mc on Fedora and Ubuntu
  2. start mc
  3. disable showing of hidden files in mc setting
  4. save settings
  5. exit mc
  6. start mc
  7. wonder why the bleep are hidden dot files showing again in mc

When I looked in my home folder I couldn't find .mc folder, after manually creating it mc saved setting without problem.

The bug is that mc expects an already existing ~/.mc folder and it is doesn't exist it doens't create new one.

Change History

comment:1 Changed 6 years ago by andrew_b

Cannot reproduce. Works as expected for me.

Please show:
1) the output mc -V.
2) the exact command how do you start mc.

comment:2 Changed 6 years ago by valentt

Ok, I have moved .mc folder to .mc.backup and started mc from my home folder, saved setting and now it works.

Don't get it why now works when previously it failed multiple times.

I'll investigate if it has anything to do with SELinux on Fedora or not.

comment:3 Changed 6 years ago by valentt

$ mc -V
GNU Midnight Commander 4.7.2
Virtual File Systems: tarfs, extfs, cpiofs, ftpfs, fish, mcfs, smbfs
With builtin Editor
Using system-installed S-Lang library with terminfo database
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

comment:4 Changed 6 years ago by zaytsev

  • Cc zaytsev added

ls -als

I think it has to do with your permissions. Like first start of mc as sudo mc etc.

comment:5 Changed 6 years ago by ossi

no, valentt's report is valid - i had exactly the same problem a few days back when i logged into a new account on a remote server. just manually creating the directory fixed the problem.
i got two new accounts that day and don't remember which one it was, but it could be either a 4.6.0 or a 4.6.2 (i *think* it was the latter).

comment:6 follow-up: ↓ 7 Changed 6 years ago by zaytsev

4.6.0 or a 4.6.2

???

There was a problem with creating the directory already, but it is solved in current master unless it's broken again.

comment:7 in reply to: ↑ 6 Changed 6 years ago by andrew_b

Replying to zaytsev:

4.6.0 or a 4.6.2

???

There was a problem with creating the directory already,

Yes, but it was fixed in #335 (changeset:ab1bdc1429df72551e790bdbba11d57c93de62a4), between 4.6.2 and 4.7.0-pre1 releases.

comment:8 Changed 6 years ago by zaytsev

Yup, this is what I was referring to...

comment:9 Changed 6 years ago by ossi

hmm, then it is a different problem, indeed ...

comment:10 Changed 6 years ago by andrew_b

I don't think that is a problem of MC.

comment:11 Changed 6 years ago by valentt

I'm using 4.7.2 on Fedora 12, it looks like in this version it is fixed. Sorry for confusion. Older versions had issue but it looks like you fixed it.

comment:12 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.2 deleted
  • Resolution set to invalid
  • Milestone 4.7 deleted

OK

Note: See TracTickets for help on using tickets.