Ticket #1907 (assigned enhancement)

Opened 7 years ago

Last modified 11 days ago

F5/F6 append filename to path in "to:" input

Reported by: powerman Owned by:
Priority: minor Milestone: Future Releases
Component: mc-core Version: master
Keywords: Cc: zaytsev
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

It's very useful to slightly alter file name while copy/move file.

Currently it's possible to do using either "source mask" feature or by manually adding full file name to destination path in "to:" input. Masks isn't really intuitive and ease to use for this simple task, it's much more ease just to modify destination file name - this way it works both in mc-mp and far. Also, masks probably much more useful while copy/move multiple files, while just editing old file name is good while copy/move single file.

I propose to automatically append file name to path in "to:" input in F5/F6 dialog windows when only one file (or directory!) involved in copy/move operation.

Attachments

file.patch (787 bytes) - added by nickk9 7 years ago.
mc.paste_src_filename.diff (5.0 KB) - added by szaszg 4 years ago.
paste original filename into "to:" field

Change History

comment:1 Changed 7 years ago by andrew_b

  • Priority changed from major to minor

Changed 7 years ago by nickk9

comment:2 Changed 7 years ago by nickk9

  • Owner set to nickk9
  • Status changed from new to accepted
  • Version changed from 4.7.0-pre3 to 4.7.1

I propose the attached patch to src/file.c. Works fine for me.

comment:3 Changed 7 years ago by angel_il

  • Version changed from 4.7.1 to master
  • severity changed from no branch to on review

branch: 1907_filename_in_copy
changeset: 97cfc65d2d30d31ea2cb0bc1bc95a09de552ab55

comment:4 Changed 7 years ago by angel_il

  • Milestone changed from 4.7 to 4.7.3

comment:5 Changed 7 years ago by andrew_b

  • Owner changed from nickk9 to angel_il
  • Status changed from accepted to assigned

comment:6 Changed 6 years ago by angel_il

  • Votes for changeset set to angel_il

comment:7 Changed 6 years ago by slavazanko

  • Votes for changeset changed from angel_il to angel_il slavazanko
  • severity changed from on review to approved

comment:8 Changed 6 years ago by angel_il

  • Status changed from assigned to testing
  • Votes for changeset changed from angel_il slavazanko to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:9 Changed 6 years ago by zaytsev

  • Cc zaytsev added

Stable candidate after testing the 4.7.3 release? I can take care of it...

comment:10 Changed 6 years ago by andrew_b

  • Keywords stable-candidate added

comment:11 Changed 6 years ago by angel_il

comment:12 Changed 6 years ago by slavazanko

See also #2276

comment:13 Changed 6 years ago by slavazanko

  • Status changed from testing to reopened
  • Resolution fixed deleted

comment:14 Changed 6 years ago by slavazanko

  • Keywords stable-candidate removed
  • Votes for changeset commited-master deleted
  • severity changed from merged to no branch

comment:15 Changed 6 years ago by slavazanko

  • Milestone changed from 4.7.3 to 4.7

comment:16 Changed 5 years ago by andrew_b

  • Branch state set to no branch
  • Milestone changed from 4.7 to Future Releases

comment:17 Changed 4 years ago by szaszg

A less (hmm... or more? ;-) "offending" solution for the problem is in Ticket#2993.

I attached patch here, because Ticket#2993 closed (as duplicate of this)...

With this patch, users can paste original filename into "to:" field.

Last edited 4 years ago by szaszg (previous) (diff)

Changed 4 years ago by szaszg

paste original filename into "to:" field

comment:18 Changed 4 years ago by angel_il

szaszg:
sorry FOR the late response... your feature already has been implemented.
just define 'Store' and 'Paste' in the 'input' section.
You can copy current filename if press shortcut of the 'Store' action (in my case is 'ctrl-c' Store = ctrl-c)
If more than one file is marked then all marked filenames will be stored in to clipboard.

NB: command prompt must be enabled.

comment:19 follow-ups: ↓ 20 ↓ 21 Changed 4 years ago by powerman

Am I understood this correctly: to edit name of copying/moving file I have to

  • (once) manually define Paste=ctrl-c
  • (every time)
    1. before F5/F6 press alt-w (default Store)
    2. press F5/F6
      • if forget to alt-w: Esc-Esc-alt-w-F5/F6
    3. press ctrl-c
      • if just realized forget to alt-w: Esc-Esc-alt-w-F5/F6-ctrl-c

How do you call this… let me guess… oh, yeah, it's USABILITY!!

What's wrong with inserting file name by default when copy/move one file?

comment:20 in reply to: ↑ 19 Changed 4 years ago by andrew_b

Replying to powerman:

What's wrong with inserting file name by default when copy/move one file?

Nothing wrong. The point is correct implementation. Initial offered patch doesn't handle some cases (see #2276).

comment:21 in reply to: ↑ 19 ; follow-ups: ↓ 22 ↓ 23 Changed 4 years ago by angel_il

Replying to powerman:

Am I understood this correctly: to edit name of copying/moving file I have to

  • (once) manually define Paste=ctrl-c
  • (every time)
    1. before F5/F6 press alt-w (default Store)
    2. press F5/F6
      • if forget to alt-w: Esc-Esc-alt-w-F5/F6
    3. press ctrl-c

just use - S-F5/F6 in this case.

Last edited 4 years ago by angel_il (previous) (diff)

comment:22 in reply to: ↑ 21 Changed 4 years ago by powerman

Replying to angel_il:

just use - S-F5/F6 in this case.

You mean:

. F5/F6 to copy/move to target dir
. Tab
. S-F5/F6 to rename
. Tab

And even this will fail if target dir already have file with original name.

Don't get me wrong, I can live (actually I do all these years) without this feature. And I'm in no way insist it MUST!!!111 be added or I'll become crazy and kill someone. :) But this is really cute small feature, which increase usability and compatibility with other file managers, won't break anything, and can't be easily replaced by anything else like alt-w or S-F5/F6.

comment:23 in reply to: ↑ 21 Changed 4 years ago by szaszg

Replying to angel_il:

Replying to powerman:

Am I understood this correctly: to edit name of copying/moving file I have to

  • (once) manually define Paste=ctrl-c
  • (every time)
    1. before F5/F6 press alt-w (default Store)
    2. press F5/F6
      • if forget to alt-w: Esc-Esc-alt-w-F5/F6
    3. press ctrl-c

just use - S-F5/F6 in this case.

As I say in Ticket#2993:
... it is not the same. With s-f5/s-f6 the target directory for copy/move is where the file exists (current_dir), not the other panel's directory (other_dir)... now, how can i copy the other_dir name into "to:"? :-(

comment:24 Changed 11 days ago by andrew_b

  • Owner angel_il deleted
  • Status changed from reopened to assigned
Note: See TracTickets for help on using tickets.