Ticket #1843 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

slow mcedit after utf8 support added

Reported by: richlv Owned by:
Priority: major Milestone: 4.7.1
Component: mcedit Version: 4.7.0-pre4
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description

mcedit is notably slow in latest releases, for example, simply scrolling down a few kb large file produces delays. according to http://www.midnight-commander.org/ticket/1417#comment:14 - because of utf8 support.

companion bug of ticket #1417 (which concerns mcview)

Attachments

forms.inc.php.bz2 (40.5 KB) - added by richlv 7 years ago.
testcase

Change History

comment:1 Changed 7 years ago by angel_il

please attach the problem file. may be trouble in color scheme...

Changed 7 years ago by richlv

testcase

comment:2 Changed 7 years ago by richlv

situation is notably improved after the last mc upgrade in slackware-current.
attaching one file where opening it and holding pgdown shows some slowness still

comment:3 Changed 7 years ago by slavazanko

what terminal (terminal emulator) you use? gnome-terminal?

comment:4 Changed 7 years ago by richlv

konsole 1.6.6, on kde 3.5.10

comment:5 Changed 7 years ago by angel_il

cp forms.inc.php forms.inc.php.c
mcedit forms.inc.php.c

maybe trouble in php.syntax or color parser...

comment:6 Changed 7 years ago by angel_il

i try edit your file forms.inc.php in 4.6.1 with current php.syntax. i don't see regression. 4.7.0 so slowly as 4.6.1 with current php.syntax

comment:7 Changed 7 years ago by angel_il

  • severity changed from no branch to on review

branch: 1843_slow_edit
changeset: 1e85261d3eb5ef5c919875fb26de585fff9fc796

comment:8 Changed 7 years ago by slavazanko

  • Milestone changed from 4.7 to 4.7.0

comment:9 Changed 7 years ago by slavazanko

  • Milestone changed from 4.7.0 to 4.7.1

comment:10 Changed 7 years ago by metux

  • Votes for changeset set to metux

comment:11 Changed 7 years ago by metux

  • Blocked By 1872 added

Buildfarm test still failed, since #1872 not merged yet ;-O

comment:12 Changed 7 years ago by andrew_b

Does this branch introduce new compile warnings? If not, please remove 'Blocked by'.

comment:13 Changed 6 years ago by andrew_b

  • Blocked By 1872 removed

comment:14 Changed 6 years ago by slavazanko

  • Votes for changeset changed from metux to metux slavazanko
  • severity changed from on review to approved

comment:15 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Votes for changeset changed from metux slavazanko to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

Merged to master.

git log --pretty=oneline e6dce1d..b925016
Note: See TracTickets for help on using tickets.