Ticket #1686 (closed task: fixed)

Opened 7 years ago

Last modified 4 years ago

[PATCH] mc.ext.in patches for DVI and DJVU from Debian

Reported by: zaytsev Owned by: slavazanko
Priority: major Milestone: 4.8.7
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

1) Use catdvi instead of dvi2tty and improve code
2) Add djvu support

Thanks to Denis Briand.

Attachments

84_use_dvicat_instead_of_dvi2tty.patch (669 bytes) - added by zaytsev 7 years ago.
85_add_djvu_files_support.patch (764 bytes) - added by zaytsev 7 years ago.
04_add_gem_extension.patch (362 bytes) - added by zaytsev 7 years ago.
06_use_default_pdf_viewer.patch (507 bytes) - added by zaytsev 7 years ago.
07_use_default_images_viewer.patch (558 bytes) - added by zaytsev 7 years ago.

Change History

Changed 7 years ago by zaytsev

Changed 7 years ago by zaytsev

Changed 7 years ago by zaytsev

Changed 7 years ago by zaytsev

Changed 7 years ago by zaytsev

comment:1 Changed 7 years ago by zaytsev

06, 07 - use "see" instead of hardcoded values. For me it's good, should we use this when possible?

comment:2 Changed 7 years ago by zaytsev

  • Blocked By 1690 added

85_add_djvu_files_support.patch <-- can be discarded

comment:3 Changed 7 years ago by zaytsev

84_use_dvicat_instead_of_dvi2tty.patch <-- uses run-mailcap (bad), needs to be updated to use kdvi and fall back to xdvi.

04_add_gem_extension.patch <-- OK.

comment:4 Changed 7 years ago by zaytsev

06_use_default_pdf_viewer.patch <-- needs to be redone to try consequently acroread, kpdf, evince, xpdf

comment:5 Changed 7 years ago by zaytsev

07_use_default_images_viewer.patch <-- should be rejected.

comment:6 Changed 7 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted

comment:7 Changed 7 years ago by slavazanko

  • Priority changed from trivial to major
  • Type changed from defect to task
  • Milestone changed from 4.7.0-pre4 to 4.7.0-pre5

looks like Debian-specific stuff:

# yum search run-mailcap
Loaded plugins: dellsysidplugin2, downloadonly, fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror.datacenter.by
 * rpmfusion-free: ftp.icm.edu.pl
 * rpmfusion-free-updates: ftp.icm.edu.pl
 * rpmfusion-nonfree: ftp.icm.edu.pl
 * rpmfusion-nonfree-updates: ftp.icm.edu.pl
 * updates: mirror.datacenter.by
Warning: No matches found for: run-mailcap
No Matches found

Also, I don't know about 'see' utility.

I think, Need to create into {prefix}/libexec/mc/ some own universal wrappers (like to 'run-mailcap').

comment:8 Changed 7 years ago by slavazanko

Related to #1721

comment:9 Changed 7 years ago by zaytsev

Hi Slava!

Please check my comments above about every individual patch (copy):

bugs/84_use_dvicat_instead_of_dvi2tty.patch <-- to be reworked
bugs/85_add_djvu_files_support.patch <-- to be accepted from Alt
bugs/04_add_gem_extension.patch <-- to be accepted
bugs/06_use_default_pdf_viewer.patch <-- to be reworked
bugs/07_use_default_images_viewer.patch <-- to be rejected, this is
Debian specific, not a bug (recommend zgv gqview?!)

Concerning your wrapper idea:

run-mailcap is a Perl script only available on Debian and Gentoo which essentially looks for the mime-type of the requested file and launches it using the association in system's mailcap database. I think it's the best way to do it, instead of making lots of wrappers that enumerate every single possible program on user's machine and try them one by one.

What do you think about literally integrating run-mailcap in mc? Sounds better than just reinventing the wheel. You can have a look at run-mailcap here:

http://packages.debian.org/unstable/net/mime-support

Better ideas are welcome.

comment:10 Changed 7 years ago by zaytsev

  • Blocked By 1721 added

comment:11 Changed 7 years ago by slavazanko

  • Blocked By 1690 removed

comment:12 Changed 7 years ago by slavazanko

  • Milestone changed from 4.7.0 to 4.7

comment:13 Changed 5 years ago by slavazanko

  • Owner slavazanko deleted
  • Status changed from accepted to assigned
  • Branch state set to no branch
  • Milestone changed from 4.7 to Future Releases

comment:14 Changed 5 years ago by slavazanko

  • Blocked By 2118 added

comment:15 Changed 5 years ago by andrew_b

  • Blocked By 2767 added

comment:16 Changed 5 years ago by andrew_b

  • Blocked By 1721 removed

(In #1721) See #2767.

comment:17 Changed 5 years ago by slavazanko

  • Blocked By 2118 removed

(In #2118) merged to master:

git log --pretty=oneline e944301..5c6ae10

comment:18 Changed 5 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from assigned to accepted

comment:19 Changed 4 years ago by andrew_b

  • Milestone changed from Future Releases to 4.8.4

comment:20 Changed 4 years ago by andrew_b

  • Milestone changed from 4.8.4 to 4.8.5

comment:21 Changed 4 years ago by andrew_b

  • Blocked By 2897 added

comment:22 Changed 4 years ago by andrew_b

  • Blocked By 2897 removed

comment:23 Changed 4 years ago by andrew_b

  • Blocked By 2767 removed

comment:24 Changed 4 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset set to committed-master
  • Component changed from mc-vfs to mc-core
  • Branch state changed from no branch to merged
  • Milestone changed from 4.8.5 to 4.8.7
  • Resolution set to fixed

comment:25 Changed 4 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.